2014년 10월 19일 일요일

Mac OSX 10.10 Yosemite installation by moving from Chameleon to Clover Bootloader @ Gigabyte B75M-D3H, HDMI & ALC887

http://macosx4pc.blogspot.kr/2013/10/maverick-109-on-b75m-d3h-unsing.html

Please refer the link above to understand my environment.

    Yosemite has finally announced on 17-Oct, but the migration from Maverick to Yosemite is not easy than I expect with following reasons : 1. Mutibeast 7.0.0 installation generated the booting error : Still Waiting for root device... with repeating, or BUG in process suhelped[1580]... with repeating, or USBMSC Identifier (non-unique).., and all the solutions mentioned with googling doesn't solve these issues, so I made conclusion that Unibeast 5.0.1 + Multibeast 7.0.0 is not the solution at least for me. Two days has been passed, so I decided to give up Chameleon/Multibeast and move to Clover bootloader.

Updated on 21-Oct : I realized that Bluebooth issues are not caused by Bluetooth but by USB3.0, because I plugged Bluetooth USB into USB3.0 port, and moving to USB 2.0 port works. So, I guess that something wrong with the USB 3.0 driver, and I found out same thing here, and now USB 3.0 is back to work! Summing up, you need to delete GenericUSBXHCI if it's installed in /S/L/E, delete it and download new driver here & install it by using Kext Drop etc.

https://bitbucket.org/RehabMan/os-x-generic-usb3/downloads/RehabMan-Generic-USB3-2014-1016.zip

Full explanation here :

http://www.tonymacx86.com/yosemite-desktop-support/144794-ga-z77x-ud5h-tips-yosemite-vs-usb-3-0-a.html

Following steps are assumed that you read the URLs above already :

Updated on 22-Oct : If this is your first time of Yosemite, you have to understand the key change versus Maverick : In MAC OSX 10.10 (Yosemite), Apple has introduced a new security policy called kext signing. Kext signing works by checking if all the drivers in the system are unaltered by a third party or approved by Apple. If they have been modified, Yosemite will no longer load the driver. So, you need to set boot argument : kext-dev-mode=1 by default for Hackintosh.

Following explanation is started from the point where my installation of Yosemite by using Unibeast 5.0 was failed to boot with Chimera 4.0 or Clover bootloader. Fortunately, I can boot new installed Yosemite by using USB created by Unibeast 5.0, and LAN is working without installed any kext file. If you want to start Yosemite by Clover from the beginning, please refer below:

http://www.tonymacx86.com/yosemite-desktop-guides/144426-how-install-os-x-yosemite-using-clover.html

You can refer my document from here is to understand Clover as an user of Chameleon :


1. Install Clover (I assume you have the mainboard with UEFI BIO, otherwise no benefit of using Clover I heard)

We have to format the disk with GUID not MBR to install Clover bootloader, and the BIOS of your mainboard would be UEFI like B75M-D3H. (I assume that no issue for you to use GUID because we usually format the disk with GUID option before installing Mac OSX)

The disk in GUID has the EFI partiton as you the picture below named EFI - /dev/disk0s1 in this case:

[boot partition is where Yosemite installed, EFI partition is where to install Clover bootloader in a same drive : you can see 209.7MB EFI partition created by itself below, this is where Clover bootload will be installed]

Now, we need to format this EFI partition before installing Clover bootloader:

sudo newfs_msdos -v EFI -F 32 /dev/disk0s1

Then, install Clover bootloader, and please make sure of the drive you want to install it, but no customization required for option. Leave it as default.


Now, you need to add the kext files fit to your system which requires to mount EFI partition to move the files:
mkdir /Volumes/efi
sudo mount -t msdos /dev/disk0s1 /Volumes/efi
Please refer if you're into these kind of commands here:

http://themacadmin.com/mounting-the-efi-boot-partition-on-mac-os-x/

Now you can see the icon of EFI partition on the desktop, Please Navigate into EFI/CLOVER/kexts folder, then create new folder there named "10.10".


Finallly, you need to move some files like FakeSMC.kext, NullCUPP...ement.kext, NVAudio.kext, Patched_1...eRTC.kext. It depends on your system, but FakeSMC.kext is required at least. I copied NVAudio.kext to enable HDMI audio of NVidia GTX 660 OC Graphic card. Recommend you to look for the latest version of these by googling, because it would be out of dated when you read this document.


You completed the installation, but one more step remains to add boot argument to Clover bootloader.

2. Clover Configurator : Easy tool to change the option of Clover bootloader.


http://www.hackintoshosx.com/files/file/49-clover-configurator/

You need to modify config.plist at /EFI/CLOVER as you see above, and Clover Configurator is the simple tool to do it.

Please copy config.plist in EFI partition at /EFI/CLOVER you mounted to the desktop, then open it by Clover Configurator.app.


After importing, move to Boot Sections by clicking the name at left pane, then check verbose, kext-dev-mode options to see the booting message to see if something wrong, you can disable verbose later by same way.


Added on 21-Oct : I realized the rebooting caused the issue on HDMI Audio & Bluetooth again strange enough. And, I found out NVidia Injection solved this issue even though GTX 660 OC should be recognized by default.

Some changes I made here (check box) :
  • Boot / Verbose
  • Boot / dart=0
  • Boot / kext-dev-mode=1
  • Graphics / Inject Intel
  • Graphics / Inject NVidia

Updated: Enabler Trim @ Yosemite GA - Clover Configurator added wrong value

http://www.tonymacx86.com/general-help/144796-yosemite-trim-clover.html

I found out the same issue as above link, Clover Configurator added wrong value different from what I stored at 'Kernel and Kext Patches'. So I modified config.plist by BBEDIT.app & store, then it works!

<dict>
<key>Comment</key>
<string>Trim Enabler</string>
<key>Find</key>
<data>
AEFQUExFIFNTRAA=
</data>
<key>Name</key>
<string>IOAHCIBlockStorage</string>
<key>Replace</key>
<data>
AAAAAAAAAAAAAAA=
</data>
</dict>

[Trim support : Yes]

For your information, the actual number registered in config.plist shown by Clover Configurator is like this :

Find :      004150504C452053534400
Replace : 0000000000000000000000




If you want to know more about the detail of Clover SECTIONS, please refer this URL:

http://clover-wiki.zetam.org/Configuration

Save this file, and replace config.plist in EFI partition, /EFI/CLOVER as I explained.

Then reboot the system to see if working well, and I found out the HDMI Audio of GTX 660 OC and bluetooth are working well.

Added on 19-Nov.2014 : You can enable the ALC887 on-board soundchip together with or without HDMI audio. You can refer following URL :

https://github.com/toleda/audio_CloverALC

It's simple though full of explanation. I can see HDMI and ALC887 line-output both in Sound.

Clover Patched AppleHDA - Installation
  1. Clover Realtek ALC AppleHDA.kext  (patch in place)
 1. https://github.com/toleda/audio_CloverALC/blob/master/audio_cloverALC-100.command.zip
 2. Download (View Raw)
 3. Double click Downloads/audio_cloverALC-100.command
 4. Password?
 5. Verify Codec? (885, 887, 888, 889, 892, 898, 1150 only)
 6. Legacy_v100202 - y/n? (887, 888 only)
  2. Restart
  3. Verify ALC onboard audio
 1. System Preferences/Sound/Output/select audio device 


Summing up, it's too early to expect the complete solution like Multibeast or Unibeast. And, it's good time to move to Clover Bootloader. But, it would be better when you read this document.

And, I recommend you to migrate your existing Maverick partition into Yosemite after clean installation of Yosemite. Which is the more simple and clean(?) method rather than upgrading your existing Maverick partition up to Yosemite.

P.S: You're wondering that how can I have Yosemite installed partition without the bootloader installed success. Good question!. I installed Yosemite into new partition by Unibeast 5, but failed to boot it with Multibeast with errors I mentioned at the beginning of this document. So, I changed my mind to install Clover Bootloader by giving up Chimera & Multibeast.

Added on 19-Nov.2014 : After update to 10.10.1, all you have to do is to reinstall USB 3.0 kext mentioned above. All others are working with same config.plist of Clover you generated.

댓글 8개:

  1. Hello, great blog post - it has been very helpful. Thanks

    Can you please share how you made the audio to work ?

    Thanks

    답글삭제
    답글
    1. Hi, thanks for your reading. I'm using HDMI audio output thru ASUS GTX 660 OC graphic card, and this card should be enabled without doing anything, but it's true only for graphic. I should do enable "NVdia Injection" for HDMI audio to make it work.

      Today, I added additional info. to enable ALC887, I tried it for you and found out It worked for me.

      삭제
    2. Hi, thanks for replying. I also installed the ALC887 kexts and it is now working

      Thanks for your help, from the UK

      삭제
  2. Hi, thanks for your blog.

    I'm trying to install Yosemite on this board with an GTX650 graphic card.
    Can you tell me if you use an DSDT file with clover ? Can you share you clover config.plist file ?

    Regards,Vincent

    답글삭제
    답글
    1. I can share you my config.plist file, so please let me know your email address to send it.

      삭제
  3. My 2600k on same board (F15 BIOS) has no overclock ability :-/ ???

    Also, benchmark scores are ~1000 less than on stock MSI P67A-GD55(B3) -- with same CPU and RAM ???!!??

    Any advice?

    답글삭제
    답글
    1. Hi, this mainboard is the entry model, so only you can do for overclokcing is to manipulate the clock speed with trial and errors but it's not recommended. No stepping step feature for this board.
      And, not sure for MSI mainboard benchmark.But, I would to start checking the settings of Clover if I were you. I'd like to recommend you to set the default value for any uncertain value in Clover.

      삭제